R - Markdown avoiding package loading messages

730    Asked by KanekoTakeda in Data Science , Asked on Jul 15, 2021

I have been using Knitr via R-Studio, and think it is pretty neat. I have a minor issue though. When I source a file in an R-Chunk, the knitr output includes external comments as follows:

+ FALSE Loading required package: ggplot2
+ FALSE Loading required package: gridExtra
+ FALSE Loading required package: grid
+ FALSE Loading required package: VGAM
+ FALSE Loading required package: splines
+ FALSE Loading required package: stats4
+ FALSE Attaching package: 'VGAM'
+ FALSE The following object(s) are masked from 'package:stats4':

I have tried to set R-chunk options in various ways but still didn't seem to avoid the problem:

```{r echo=FALSE, cache=FALSE, results=FALSE, warning=FALSE, comment=FALSE, warning=FALSE} 
source("C:/Rscripts/source.R");
```

Is there any way to comment out these messages?

Answered by Elayne Balding

To avoid package loading messages or r markdown hide warnings, you can suppress the warnings temporarily as follows:

defaultW <- getOption("warn") 
options(warn = -1)
YOUR CODE
options(warn = defaultW)
You can also use the include = FALSE to exclude everything in a chunk.i.e.,
```{r include=FALSE}
install.packages("ggplot2")
```
To only suppress messages:
```{r message=FALSE}
install.packages("ggplot2")
```

Your Answer

Interviews

Parent Categories