Gcloud Command Not Found - While Installing Google Cloud SDK

580    Asked by Amitraj in Big Data Hadoop , Asked on Nov 17, 2022

I am on a mac and am trying to install the Google Cloud SDK (including the gcloud command line utility) using this command in terminal

curl https://sdk.cloud.google.com | bash as seen at

It got all the way to the end and finished but even after I restarted my shell, the gcloud command still says it's not found.

Why isn't this installation working? what if gcloud command not found ?

Answered by Andrea Bailey

So below is my previous fix for the problem - command not found gcloud, but it turns out it isn't permanent. It works but every time you restart Terminal, you'd have to do the same thing which isn't practical. So that is why I suggest you delete the current google-cloud-sdk directory, and just redo the installation. Be sure (as Zachary has mentioned) to answer yes (Y) to the prompt Modify profile to update your $PATH and enable bash completion? (Y/n).

Here is my old answer, but just redo the installation:

I had the same problem, gcloud wasn't working for me. But then, in the same directory as my google-cloud-sdk folder which I had just installed (my home directory), I found this file called test. Inside this test file I found two commands:

# The next line updates PATH for the Google Cloud SDK.
source '[path-to-my-home]/google-cloud-sdk/path.bash.inc'
# The next line enables bash completion for gcloud.
source '[path-to-my-home]/google-cloud-sdk/completion.bash.inc'
After I ran these two source commands in terminal, gcloud worked!

Your Answer


Parent Categories